FAQ

macOS 10.15.7 (Catalina) or 11.0 (Big Sur)

Red Hat Enterprise Linux (RHEL) / CentOS version 7.6 or 8.2

BRTT maintains community-discussion pages at the following address:

Feature Request and Community Discussion Pages

These pages may be used for discussion of topics of interest to the Antelope User community, and especially for feature requests for specific programs and utilities, and for the Antelope platform in general.

When posting feature requests, please limit requests to one feature per post!! You can make as many posts as you wish to itemize different features of interest. Putting only one request in each post makes it far easier to sort posts into priority order, and most importantly encourages other users to vote on the requests for which they concur.

If you are interested in specific pieces of software, please vote on your features of choice! We have a huge development agenda and use these vote-driven lists to prioritize what goes into our next release.

Qualifying U.S. universities may apply for a free license to run the latest version of Antelope via our Free License Program for U.S. Education and Academic Research.

We are happy to provide this free-of-charge program to support research and education.

We do however have some restrictions, first of all to ensure the community has our latest tools, and second to limit the impact of this program on our resources.

In order to participate in this program, you must run the latest version of Antelope.

BRTT will not provide or renew licenses for older versions of Antelope under the free education and research program.

All free licenses have at maximum a one-year duration.

Please do not ask us to make exceptions to this policy. If we were to make exceptions for one party, it would treat all other parties unfairly. Even our paying customers are encouraged to stay current with the latest version of Antelope such that they receive all the latest capability advances, bug fixes, format updates etc.

If you want to continue to use Antelope under the free educational and research program after your current license has expired, you will have to download the latest version of Antelope and request new licenses.

If there are problems upgrading to the current version of Antelope, BRTT recommends running a virtual machine (for example via VMWare) that creates a operating environment instance on which you can use Antelope. The only requirement there would be that the virtual machine would have to be able to see the outside internet and have a stable external IP address (per notes_licensing(5)).

Executive Summary

Antelope is shipped electronically via an ISO image. This image must be downloaded, then mounted on your machine. Run the script

  1. ./Install_antelope

at the top of the mounted directory, follow the installer instructions to install Antelope, then request a license to run Antelope. 

Itemized Steps

  1. Obtain a copy of the Antelope ISO image
  2. Mount the ISO image on your computer:
    • For Mac OSX machines, this should be as simple as typing
      open Antelope5.10.iso
      at a terminal prompt, or clicking on the ISO image file in the Finder.
    • For Linux machines, as the root user execute
      mount -o loop Antelope5.10.iso /mnt
      at a terminal prompt.
  3. Change directories into the top-level mounted directory of the ISO image (Usually /Volumes/Antelope_5.10 on OSX or /mnt on Linux).
  4. Launch the installer script ./Install_antelope from a terminal prompt (or double-click on it from the Finder in OSX)
  5. Follow the instructions provided by the installer
  6. Request a license to run Antelope
  7. Unmount the install image:
    • On Mac: Eject the disk image for the Antelope installer in the Finder.
    • On Linux: change out of the /mnt directory, then as the root user execute
      umount /mnt
      at a terminal prompt.

Separate Items

Several items are not included in the main Antelope ISO that may still be of interest to some if not most users:

  1. If you wish to use high-resolution maps with Antelope, and did not choose the option to install the supporting map data during the Antelope installation process, you may do so later per the instructions in Installing High-Resolution Map Data section below.
  2. If you did not choose the option to install the user-contributed code during the Antelope installation process, you may do so later per the instructions in Installing Contributed Code.
  3. If you are building software with Antelope and wish to use the same toolchains we used to construct Antelope itself, see the instructions in the Installing Toolchains section below.
Antelope provides mapping software that can use global image and Digital Elevation Model (DEM) data. These global data sets are almost 5 Gbytes in size. If you did not install the map data in the installation process you can manually install these data with the install_mapdata(1) script:

After Antelope is installed, run the install_mapdata(1) script. Note that the install_mapdata(1) script requires a working internet connection:
  1. Source the appropriate setup file ($ANTELOPE/setup.csh or $ANTELOPE/setup.sh)
  2. Run the program install_mapdata(1) from a terminal window or shell prompt
The Antelope Users Community produces open-source Contributed Software that is based on Antelope and designed to be used in conjunction with it. The contributed code is separately hosted by the Antelope Users Community. The contributed code may be installed:
  • As an option during the Antelope installation process;
  • At a later time via the supplied install_contrib(1) script;
  • Downloading and installing the compiled tarball by hand; or
  • By compiling the contributed source-code oneself.

Itemized Steps — option A (Antelope installer option)

The default option to install the contributed code is to approve download and unpacking of the contributed-code tarball when prompted by the main Antelope installation program. This method requires a working internet connection that can connect to the appropriate web-site to download the contributed-code tarball:
  1. Install Antelope
  2. During the Antelope installation process, respond “Yes” when prompted by the installer to “Download contributed code?” (one of the last steps in the installation process).

Itemized Steps — option B (install_contrib(1) script)

If you choose not to install the contributed code during the Antelope installation process, or you do not have an internet connection at the time, you may install later via the install_contrib(1) script. This option also requires an internet connection:
  1. source the appropriate setup file ($ANTELOPE/setup.csh or $ANTELOPE/setup.sh)
  2. Run the program install_contrib

Itemized Steps — option C (download and install by hand)

In lieu of running the install_contrib(1) script, you may download and install the relevant files by hand:
  1. Check the current download location and filename:
    % pfecho install_antelope 'contribcode_params{download_site}' 'contribcode_params{filename}'
    contribcode_params{download_site}       https://github.com/antelopeusersgroup/antelope_contrib/releases/download/5.10
    contribcode_params{filename}    Darwin_x86_contrib.tar.bz2
    
    
  2. Download the file with web-browser, wget or similar utility:
    % wget 'https://github.com/antelopeusersgroup/antelope_contrib/releases/download/5.10/Darwin_x86_contrib.tar.bz2'
    
    (Note that the URL will change depending on the platform you’re on)
  3. Install the contributed-code file:
    % mv Darwin_x86_contrib.tar.bz2 /opt/antelope
    % cd /opt/antelope
    % bunzip2 -c Darwin_x86_contrib.tar.bz2 | tar xvf -
    

Itemized Steps — option D (compile from source)

If you wish, you may download the contributed-code source and compile it yourself:
    1. Make sure Antelope is installed
    2. Source the appropriate setup file $ANTELOPE/setup.csh or $ANTELOPE/setup.sh
    3. In a terminal window or shell, run the following:
      1. % cd $ANTELOPE
      2. % mkdir contrib
      3. % cd contrib
      4. % git clone https://github.com/antelopeusersgroup/antelope_contrib src
      5. % cd src
      6. % make Include
      7. % make install
Note that if developers have committed changes to the contributed-code repository that are incompatible with the version of Antelope you are running, the affected contributed-code programs may not work. We reiterate that BRTT does not provide support for contributed code, including for compilation problems. For support on compiling and/or using contributed-code programs, please contact the originating author(s) (hopefully listed in the man-pages for the programs/libraries in question), or the Antelope User Community.

Antelope is built with standardized toolchains (i.e. compilers and compilation utilities) which we make available to our users.

Installing toolchains with the install_toolchain(1) script:

After Antelope is installed, you may download and install the appropriate toolchain for your version of Antelope with the supplied install_toolchain(1) script. Note that the install_toolchain(1) script requires a working internet connection. You may need to use the getid(1) program to acquire the nickname of the toolchain used with your version of Antelope:

  1. Install Antelope
  2. source the appropriate setup file ($ANTELOPE/setup.csh or $ANTELOPE/setup.sh)
  3. Run the command
    getid toolchain

    from a terminal window or shell prompt to get the name of the relevant toolchain (see the getid(1) man-page for further details)

  4. Run the command
    install_toolchain 

    from a terminal window or shell prompt, substituting the toolchain name obtained from the getid(1) command as explained above (see the install_toolchain(1) man-page for further details)

Antelope supports two main branches of Linux, RedHat Enterprise Linux (RHEL) and CentOS Linux.

Specifically, for Antelope 5.11:

We can make no promises nor offer support for Antelope on other versions of Linux.

Note that in order to use node (serial-number-based) licenses on Linux machines you need to run the Antelope amd(1) daemon as root, due to technical limitations of modern Linux. All of Antelope does not need to run as root, just the amd(1) daemon (usually via a turnkey boot script). See the amd(1) and S99amdd(1) man-pages for details.

We arrived at support for these two Linux variants after a survey of our Enterprise customers. Their overwhelming consensus at the time was to pick RedHat.

While we understand there are many extant versions of Linux available which may be of interest, in practice there are far too many for us to support. Witness the number of valid variants shown by the Linux Distribution Timeline on Wikipedia. In order to support any of these releases we need to run a copy in-house, then pay staff to investigate and resolve any problems that arise on each particular version. In practice we cannot properly support more than a couple versions of Linux without substantially increasing the cost of our software. We regret any inconvenience this may cause.

We often hear arguments that one or another version of Linux (Fedora, Scientific Linux, etc.) is almost or essentially the same as one of our supported versions, and that Antelope should therefore work on the named variant. While this may be true to zeroth order, for operations-grade software such as Antelope, the few small differences amongst nominally similar Linux versions are sometimes enough to create performance problems that degrade the application below our quality standards. These problems, when they occur, are frequently insidious and extremely resource-intensive to find and fix. We are thus back to the point made above, that we cannot afford to support more than a couple versions of Linux. We are forced to interpret that version support in the strictest sense.

The ObsPy Python Framework for Seismology is a useful complement to Antelope’s extensive application-development libraries, interfaces and utilities for real-time streaming signal processing and earth monitoring.

Since ObsPy is not BRTT code, we do not ship it with Antelope nor can we provide support or advice for it directly.

Nevertheless, due to continued community interest in the ObsPy package, we have incorporated the modules needed by ObsPy into the Antelope Python interpreter, and also written an install_obspy(1) script in the Antelope contributed-code software repository to install ObsPy with one step.

Presuming you have installed the Antelope contributed-code, either during Antelope installation via the Antelope installer or with the install_contrib(1) program after the fact, execute the command


% install_obspy

to install the ObsPy tools into Antelope Python.

For problems with the Antelope Python interpreter, please write to support@brtt.com.

If you are having trouble with ObsPy, itself, please contact the ObsPy authors.

Antelope is released yearly. The following table shows the history of Antelope releases.

VersionRelease DateOperating Systems
Antelope 5.11

Antelope 5.10
May, 2021

May, 2020
RHEL/CentOS Linux 7.6 or 8.2;
macOS 10.15.7 (Catalina) or 11.0 (Big Sur)

RHEL or CentOS Linux 7.6 Mac OSX 10.14.6
Antelope 5.9May, 2019RHEL or CentOS Linux 7.4
Mac OSX 10.13
Antelope 5.8May, 2018RHEL or CentOS Linux 7.4
Mac OSX 10.13
Antelope 5.7May, 2017RHEL or CentOS Linux 6.8
RHEL or CentOS Linux 7.1 to 7.3 with IP-based licensing
Mac OSX 10.9 to 10.12
Antelope 5.6May, 2016RHEL or CentOS Linux 6.7
RHEL or CentOS Linux 7.1/7.2 with IP-based licensing
Mac OSX 10.9, 10.10, and 10.11
Antelope 5.5May, 2015RHEL or CentOS Linux 6.2-6.6
RHEL or CentOS Linux 7.x with IP-based licensing
Mac OSX 10.8, 10.9, and 10.10
Antelope 5.4May, 2014RHEL or CentOS Linux 6.2
Mac OSX 10.8 and 10.9
Antelope 5.3May, 2013SPARC Solaris 2.10
x86_64 RHEL Linux 6.2
INTEL Mac OSX 10.6.8
Antelope 5.2-64May, 2012SPARC Solaris 10
x86_64 RHEL Linux 6.2
INTEL Mac OSX 10.6.8
Antelope 5.1-64May, 2011SPARC Solaris 2.10
x86_64 Linux 2.6.34.7
INTEL Mac OSX 10.6.6
Antelope 5.0-64June, 2010SPARC Solaris 2.10
x86_64 Linux 2.6.22.19
INTEL Mac OSX 10.6.3
Antelope 4.11May, 2009SPARC Solaris 2.10
x86 Linux 2.6.22.5
INTEL Mac OSX 10.5.6
Antelope 4.10May, 2008SPARC Solaris 2.10
x86 Linux 2.6.11.4
INTEL Mac OSX 10.4.11
Antelope 4.9May, 2007SPARC Solaris 2.8
x86 Linux 2.6.11.4
PPC & INTEL Mac OSX Tiger
Antelope 4.8April, 2006SPARC Solaris 2.8
x86 Linux 2.6.11
PPC Mac OSX Tiger
Antelope 4.7April, 2005SPARC Solaris 2.8
x86 Linux 2.4.19
PPC MacOSX 10.3
Antelope 4.6March, 2004SPARC Solaris 2.8
x86 Linux 2.4.19
Antelope 4.5February, 2003SPARC Solaris 2.8
x86 Solaris 2.8
x86 Linux 2.4.19
Antelope 4.4January, 2002SPARC Solaris 2.7
x86 Solaris 2.7
Antelope 4.3, 4.3uDecember, 2000SPARC Solaris 2.7
x86 Solaris 2.7
Antelope 4.2, 4.2uFebruary, 2000SPARC Solaris 2.6
x86 Solaris 2.7
Antelope 4.1.2May, 1999
Antelope 4.1November, 1998

To obtain a license for Antelope:

    1. Install Antelope from the download ISO 
    2. Run the register_antelope(1) command

The register_antelope(1) GUI will run as a normal part of the Antelope installation process. This program will request that you fill out a form with relevant details. When you hit the Register button, the license request will be sent to register@brtt.com.

If you already have Antelope installed and need to renew or request a license, you may run register_antelope(1) from the command line after properly setting up your Antelope environment (register_antelope(1) resides in $(ANTELOPE)/bin). 

The register_antelope(1) program also creates a copy of the license request in the text file

~/BRTT-license-request

When you submit a license request, you should receive an acknowledgment email from our auto-responder within a few minutes. If you do not receive the acknowledgment email, or if you are not on a networked machine, you may send the file ~/BRTT-license-request manually by attaching it to an email to register@brtt.com.

PLEASE DO NOT HAND-EDIT AND RESUBMIT old license requests. Doing so almost invariably interferes with our automatic pre-processor, delaying our response to your request. The only supported way to generate an Antelope license-request is via the register_antelope(1) command.

Our average response time for valid license requests is 2-3 business days. For questions about obtaining licenses, please send email to register@brtt.com.

If you are having a problem getting an existing license or recently issued license to work, please open a support ticket by sending email describing the problem to support@brtt.com.

 Due to the regrettable demise of Sun Microsystems, Inc., in 2011 BRTT announced the End of Life for Solaris/SPARC support within Antelope. We continued to produce versions of Antelope for Solaris/SPARC from 2011 to 2013. The final version to support Solaris/SPARC was Antelope 5.3, released in May, 2013. In Antelope 5.4 and beyond we continue support for Mac OSX and RHEL/CentOS Linux platforms.

When submitting a support request, please help us provide a quick solution by providing detailed information. Remember that BRTT must be able to understand and reproduce your problem in order to solve it.

While in principle we can sometimes puzzle through partial information to recognize what’s going wrong for you, in practice this can take a lot of time that slows down our response, plus we may not be identifying the same things that you are seeing in context.

In order to help you, we need:

  • One or more complete sentences explaining what problem you see and why you consider it a problem, even if it may seem obvious to you.
  • The exact and complete command line(s) you invoked
  • The input data
  • The exact output
  • What you expected
  • Which difference between expected and observed is problematic
  • A short, reproducible test-case if appropriate
  • The tarball from the appropriate snapshot command

In particular, it is not sufficient merely to cut-and-paste raw program output without any explanation of why you consider it problematic, then submit that snippet as the entirety of your support request.

To generate the requested snapshot(s), please use the most appropriate snapshot command for your situation:

  • rtsnapshot(1) (real-time system problems)
  • dbsnapshot(1) (database problems)
  • dbloc_snapshot(1) (dbloc problems)
  • syssnapshot(1) (system problems)
  • licsnapshot(1) (license problems)

Please include the resulting tarball from one or more of these commands along with the text of your support request.

Effective problem reports are often time consuming and difficult. Please consult the man pages bugs(5) and reporting(5) for some guidelines.

Our software is proudly named after the Pronghorn Antelope. Pronghorns are native to the Americas and are the fastest land mammals in the Western Hemisphere.